Roku root for telnet access

This section is for all Roku devices
Post Reply
Android 1.0
Posts: 1
Joined: Fri Dec 16, 2016 7:03 pm

Roku root for telnet access

Post by ssybesma »


I have a Roku HDMI, on which this should work.

I tried the Roku root to see what would happen. (Went to "Select development webserver password...)

After entering exactly (between the quotes) ";wget -O/tmp/;sh /*/;" and clicking OK, the behavior on mine is to blank what was just typed and it never reboots. On the video, the guy hit OK after typing and the typed line remained about 37 secs until it rebooted on its own. I don't know why the line clears when I click OK. Is that a result of the newer firmware, to blank a password line the Roku thinks is an attempt to inject a command?

I have the newest which at the time of this posting is: version 7.5.0 build 4099-09

I was hoping at least to get the non-persistent telnet server to start up. I realize the persistent one was prevented by a previous update.

I tried (between the quotes) ";telnetd -l loginsh;" as dice.
Android 1.0
Posts: 2
Joined: Fri Feb 23, 2018 8:59 pm

Re: Roku root for telnet access

Post by sycohexor »

same here, but i have a 3600X -roku stick with 8.0.0 build 4143-24, im thinking of trying to make a zip file that uploads via rokudev webserver that could replicate this, but dont know how i would go about doing that. it also doesnt work on the 3500x roku stick with build 8.0.0 4128-09
Post Reply