Generic Root Guide: Works for MOST of the platform.

Looking for help doing something. This is one of the best places to start.
Android 1.0
Posts: 1
Joined: Mon Aug 19, 2013 7:19 pm
GTV Device Owned: Sony NSZ-GS7 (v2 streamer)

Re: Generic Root Guide: Works for MOST of the platform.

Post by clevertrevor777 »

So it looks like the non-persistent root steps should work for the NSZ-GS7 correct? I get through everything up through step 7, and instead of "#", I get:

"Entering character mode
Escape character is '^]'."

and it seems I do not have root access - I am unable to push Superuser.apk to /system/app (failed to copy ... Read-only file system).

I was able to push Superuser to the tmp folder and install it from there, but it doesn't do much good without root access or the binary...

Any advice? Forgive my ignorance - adb is very new to me...

Android 1.0
Posts: 7
Joined: Sat Aug 04, 2012 12:20 pm
GTV Device Owned: Logitech Revue

Re: Generic Root Guide: Works for MOST of the platform.

Post by mrdavis1118 »

root does not equal automatically making file system read/write, it would have to be remounted. I have a revue with locked bootloader,so even if you remount read/write, and then modify something, you're breaking the signature which will wreck havok on reboot. I dont know if your device is the same way. Im hopeful that perhaps there will be someway to remount cloned partitions from a usb drive that have full read/write, so we are not breaking the signatures and if i need to reboot and remount again i would just run this root again from pc. I would imagine it would be scriptable from the pc side, thus giving a form of semi persistence i guess. Would love for someone to chime in on my idea.
Android 1.0
Posts: 26
Joined: Sat Mar 03, 2012 12:13 pm

Re: Generic Root Guide: Works for MOST of the platform.

Post by 22350 »

I am using this method on my 40 inch sony. I am on mac and not having a lot of luck.

I am able to connect to the tv over wifi, using impactor. What is strange is that the only option i see in the drop down is for the persistent root method. "echo ro.kernel.qemu=1 > /data/local.prop"

I try that and it goes through the installation, up to "running command" and the program crashes.

I also tried to run "# drop SuperSU su to /system/xbin/su" but the program crashes too.

I tried the same process in windows. The program doesn't crash, but it doesn't appear to do anything.

I run adb devices in a terminal window and my tv's ip address shows as connected.

Can someone clear up what's going on?
Post Reply