Page 1 of 1

How can I reverse Cuberoot's OTA blocking???

Posted: Wed Apr 02, 2014 2:49 pm
by Cadstar
OK, have had my Cube for a long time now - not really happy with it at all, but there have been several updates released now that likely will make me a bit happier if I could install them! Due to using Cuberoot the day I opened the box, I cannot get any updates. It tries but the download fails each and every time. Crazy thing is that Cuberoot did not even work for me as far as rooting goes - I ended up using Cydia Impactor - which worked great by the way.

Now I have reversed as much as I was abe to, remove SU apks, reset box to factory defaults, etc, etc. Nothing works - I can successfully unroot myself but I need to know what the hell Cuberoot did to "disable OTA uodates" so I can fix it. I do not understand why factory resetting the box doesn't wipe out all this mess. I desperately want the latest update but cannot install it!!! Very agrivated!

Can someone who was part of the Cuberoot team please help me out here? Wish you guys had thought to put some kinf of reverse mechanism into Cuberoot.

My other alternative is to install the update myself manually. GTVHacker was nice enough to provide links to the new firmwares righ on the main Asus Cube page, but for the life of me I cannot figure out how to push it onto the device!! I am a Linux systems admin by trade and certainly no stranger to adb - in fact I used adb over tcpip to push the SuperSU Pro license, root explorer, and even AdAway (which appears to work just fine). I have no idea how to do a firmware update on the Cube using adb and cannot find any info on anyone actually doing this. (I am not afriad to open the Cube up if that's what it takes!)

If anyone can provide me instructions on how to reverse the Cuberoot changes (I hae NOT patched the "vulnerability" as I didn't want to hose future attepts at messing around with the box), or (even better) tell me how to update via adb with this firware file I have already; I would be in your debt!
Even if that all means I cannot re-root again afterwards - I can live with that if need be.

Just occufrred to me that maybe I can rename the file to and push it to sdcard/ directory then reboot. I have done that before and it worked, but that was on Asus Transformer tablets, not a GoogleTV so no idea if that will work or not. I will give that a shot tonight and report back all the same.

Couple other things
1 - Gripe: why the hell is there no way to reboot the Cube from it's menu's???
I have to either yank power cord and wait a few secs, or adb reboot it from my TF701T tablet which is setup as the one machine that can access the Cube
that way (I use Better Terminal Emulator and love it! Plus it's awesome that Android 4.3 has adb there already - never tried that on the older TF101, TF201,
or TF700T so I don't know for sure if every Android OS has this built in or not - I am thinking they all do - very handy indeed to not have to freaking install it
and mess around for 2 hours getting it to work right!.

2 - What the hell is this V2 Asus Cube that I am seeing now???? I cannot find any information anywhere on what makes it a V2! That's annoying as hell.
From the pics of it I have seen there is now an IR blaster with 2 outptut ends on it now - maybe that's all they did? Sounds great to me - right now I can only
control the FiOS cable box or the TV, not both. A dual head IR blaster would make me real happy? Anyone know what the changes are??? I see
them real cheap right now, and with the problems this V1 is giving me maybe I should just bite the bullet and buy another Cube to get the V2!

Sorry for the long-winded post. I am always being told at work that I give out waaaay to much info. I like to be thorough!

Hoping someone can help - Thanks!


P.S. - Why has no other Cube owner bother to take my dumb pole on is the Cube junk or not??
I am a huge Asus fan but thinking now that the Cube was a mistake, maybe I will just get one of the little USB dongle GoogleTV devices ....

Re: How can I reverse Cuberoot's OTA blocking???

Posted: Thu Apr 03, 2014 2:35 pm
by Cadstar
Ok putting the update into /sdcard directory, naming it did not work - rebooted and it didn't update. I then tried the very same thing but put the file in the root of an externa USB drive and plugged it in - still no update. Gave up for the night and went to bed. Today I started to google recovery and Asus cube and found there is a page right here on GTVHacker that shpws how to install one!! Doh!

You guys need to link to that on the main Cube page - I have scoured that page 100 times and I never knew you had this posted already - damn, feel like I wasted a lot of time.

I will give the custom recovery preocess a shot tonight and see how it works. Maybe that will allow me to flash this damn update, then I can re-root and be a happy man again. Still thinking about buying a V2 Cube though - just wish I knew what else besides dual IR blaster you get with a V2.

P.S. AdAway seems to be working great on my Cube!

Re: How can I reverse Cuberoot's OTA blocking???

Posted: Fri Apr 04, 2014 6:45 am
by Cadstar
Well I got the custom recovery installed just fine. Works great too. Only have one problem now - I can only access the recovery, cant boot into android and I am not sure why. I was fine until I tried to install the Asus update from recovery - before that it would boot normally and only go to recovery if I ran an "adb reboot recovery". All was good - then I installed the latest OTA found on the main page - now it only boots to recovery.

I can take any of the 3 OTA updates shown on the main page, rename them to and place in root of a FAT32 USB flash drive, insert into the Cube and boot up - goes right to recovery (which it should not - from what I understand at least - I should have to "adb reboot recovery" to get there since no buttons to hold down on the Cube during boot to get there like there is with phones and tablets"). The custom reocovery has option 1 - install from USB.
When I try that it seems to work fine - takes about as long as I would expect, prints messages along the way stating "copying data...", then "50% Done", "20% Done", "10% done", then I get a complete, then success message with a press Q to go back.
So I go back then hit 5 to reboot - it reboots back to recovery again - also noticed optipon 3 for device info no longer works so even though recovery shows me success I think it failed to completely install. Tried unplugging annd leaving it alone for a while, but on next boot same thing - only boots to recovery - acts like the OTA install is NOT actually installed, but I am not 100% sure because the update process works fine. I tried to re-apply the package again (first renaming to and that works fine still, but doesn't help - still this damn thing will only boot to recovery. (At least I have not bricked it yet!)

I tried the same with all 3 of the latest OTA's shown on the site - same exact thing happens with every one of them. I am at a loss as to what to do here. Never used UART before but I am looking into doing that today - I opened the cube up and see it has a nice 4pin UART right in the front so I don't have to tear off the EMI shields or anything. Just not yet clear on how to connect - think I may need a 4pin UART to USB converter cable to do this, not sure ....

Guess I may have to nudge one of the Cuberoot/Recovery authors here in the site so that someone will read this that understands what I am talking about and can help me out with this. Don't know why none of them are reading these forums anymore. As of now I have 10 views but only myself responding so people that can answer don't seem to be reading this.

I know I must be close to resolving the issue, I am missing something along the way, really would be nice to get some help....

Re: How can I reverse Cuberoot's OTA blocking???

Posted: Sat Apr 05, 2014 10:27 pm
by speakxj7
I don't have a solution for you, but in light of the recent groupon+rebate going on the cube, there will probably be more interest coming in the near term. I'll be looking to do something similar soon...

Re: How can I reverse Cuberoot's OTA blocking???

Posted: Mon Apr 07, 2014 7:53 am
by Cadstar
OK, well still no luck - I am stuck in Custom Recovery hell - my V1 Cube only boots to recovery, does nothing more. I have no adb access as it isn't booting so I am stuck here. Not having much luck finding info on how to connect to the UART pins either. I have a USB to serial adapter here but not sure if it's a good idea to do much poking around. I have a USB to UART cable on the way that should get me all I need.

Hopefully the cable will give me some low-level access thru UART and perhaps I will be able to revive this Cube eventually. I will post any further info I can gather here. Might be selling this V1 cheap if I can get it fixed!

In the meantime UPS just delivered my new V2 Cube, I'll be running home at noon to connect this baby and get it going. From just the unboxing I only see the one difference: the IR Blaster has 2 outputs (been waiting for that!). Be interesting to know if it will do a firmware update once I get it setup. I'll post more info as need be ....

I think I can answer my original question though, I found the answer within the GTVHacker secure boot file:

Code: Select all

ui_print("- Moving OTA Certs to prevent OTA updates");
run_program("/system/xbin/busybox", "mv", "/system/etc/security/", "/system/etc/security/");
So it looks to me like root access, and then move back to should resolve the issue of how to reverse the changes that prevent OTA updates. If I could get my V1 Cube to boot I would give it a shot......

Will post more when I know more.

Re: How can I reverse Cuberoot's OTA blocking???

Posted: Mon Apr 07, 2014 10:09 am
by Cadstar
Initial thoughts: after just spending maybe 20mins getting the new unit setup I can say it's much faster than my V1 ever was. I dunno if it's this latest firmware or what but it seems like 99% of the lag I am used to is not here.

Had to do a firmware update on first boot - hell it came up as an Asus Qube! Updated firmware, setup my google accounts, setup wired network, setup wireless network, setup a couple BlueTooth devices, etc - all went well, I had no problems at all.

If I have any more observations on the new V2 unit I will post them, until then just waiting for a cable I can use to debug/unbrock my V1 device ......

Re: How can I reverse Cuberoot's OTA blocking???

Posted: Wed Apr 09, 2014 5:30 am
by Cadstar
Doing some research I find I was smart in not just probing around the UART without knowing some details. It appears you have to have that converter built into the cable or you will cook the chip in the android device - there is voltage level shifting that must go on:
To connect computer to tablet UART, you will need either USB-to-TTL or RS232-to-TTL converter. Level shifting is needed due to different voltage domains used in computer and tablet.
Note: Do NOT connect computer COM port (RS232) directly to tablet UART
Should have my cable soon, I can't wait to hook up and see if I can get a full console without any further messing around .....

Re: How can I reverse Cuberoot's OTA blocking???

Posted: Fri Apr 11, 2014 9:35 am
by Cadstar
It appears I ordered the debug cable from the wrong place on Amazon - it's on it's way and shipped but expected delivery is next month! Seems to have been shipped with international post, no tracking available. The other 3 items I ordered that day all showed up already.

So I am ordering from a different source today (these things are cheap). I don't need it right away but I really want to play around with this UART connection and see if I can get the older Cube booting properly again.

Wasn't paying enough attention when Amazon showed 17-28 days for delivery on something that was in stock - I should have realized the problem sooner! Oh well, activated my free trial of Amazon Prime which bumped this new cable up to 2 day delivery - so I'll have it by Tuesday.

Here is the new one I ordered that does ship from within the US for anyone else looking to do this: ... UTF8&psc=1


How can I reverse Cuberoots OTA blocking

Posted: Tue Sep 10, 2019 11:00 pm
by AvesComer
Thank you RainerPrem for your new answer.

I know how URV production station works.

I guess my issue is more a game bug. On shipyard station DEVRIS, ALBION, HOL, OMYCRON when i ask to shipyard to make me a construction ship and i select details about this ship, i can see every station that it can build. When i select details of URV BTO station, i can see what she produces. In this list, there are every typ of URV but no assault URV....

I ask you again, can you see assault URV on station product in your game ?