Page 2 of 2

Re: Hisense Pulse Root For Dummies by Yellowmann

Posted: Wed Apr 02, 2014 8:19 pm
by popeyeistheman
I can't get ADT to talk to my device.

My HiSense Pulse just arrived. It has firmware version 3.2. It did ask if I wanted to take the update and I refused. Looking at the Network settings, it shows the assigned IP as (I have no idea what the /24 means, but my router also shows assigned to the same Wi-Fi MAC address as shown on the Pulse).

When I go into the platform-tools folder and type in: "adb connect" I get back "unable to connect to"

I've tried pinging the IP and it works great. I tried connecting an ether cable and deleting the wi-fi password. The ether info showed up on the Pulse and in my router setup. It pinged great, but adb is unable to connect.

I tried using the adb kill-server followed by adb start-server. I get the message:

*daemon not running. starting it now on port 5037 *
*daemon started successfully *

I tried typing "adb connect" I got back "unable to connect to"

I'm not sure what I'm doing wrong, but I can't seem to get the pulse talking to adb. It'll ping just fine, though, and my router knows it's out there. Things work great as long as I don't want to root.....but I do want to root!!!!

Please help.

Re: Hisense Pulse Root For Dummies by Yellowmann

Posted: Wed Apr 02, 2014 8:19 pm
by popeyeistheman
I might have gotten further. On the HiSense menu system I found a "Development" tab under Applications.

There are three option in development:

1) Remote debugging (I checked it)
2) Debugger IP address (I set it to the IP of my computer I'm running adb on)
3) Mock locations (I checked it although I have no idea what it does)

Now, when I type "adb connect" it gives back "connected to"

When I next type in "adb root" it gives back "adbd cannot run as root in production builds" I'm not sure what that means, but it doesn't sound good.

I tried moving forward and it won't let me push to the device. It says "failed to copy '' to '/tmp/': Permission denied" I am probably denied as I can't get to the root.

I did not update software. It did ask if I wanted to and I declined. Looking at "", though, they say:

Update History

MASTER.user.hisense.20121122.124750 (BOX_2.22a.C0920_E_release) - Launch version, shipped on the box
MASTER.user.hisense.20121212.182643 (BOX_2.31a.C1204_E_release) - First OTA (12/31/2012). Removes root. Do not update to this. Download

My unit, as delivered, shows firmware 3.2 and Build number: MASTER.user.hisense.20130607.190756

That sounds newer than the first OTA. Maybe I'm just screwed and can't root this unit. It did show that there is a software update available when I was setting the unit up (so I thought I was golden here), but maybe the software is already has is still too new. Anybody know anything on this?

Re: Hisense Pulse Root For Dummies by Yellowmann

Posted: Thu Apr 10, 2014 6:11 am
by popeyeistheman
Hello, hello, there anybody in there??

Anyone got any helpful advice?

Thanks ;)

Re: Hisense Pulse Root For Dummies by Yellowmann

Posted: Tue Apr 15, 2014 12:50 pm
by supercalla
I am interested in rooting my pulse, but my firmware has been updated and running the current version. Can I still root it?