OTA Update.zip for NSZ-GS7

cj_000
1.6 Donut
Posts: 121
Joined: Fri Jul 29, 2011 2:13 pm

Re: OTA Update.zip for NSZ-GS7

Post by cj_000 »

Well the issue isn't that the update is too old, it's the fact that the update is a US update trying to be applied to an EU box.

If you look at the start of the updater script (in the update):

Code: Select all

assert(getprop("ro.product.device") == "NSZGS7" || getprop("ro.product.device") == "");
assert(package_extract_file("system/bin/sony_version_checker", "/tmp/sony_version_checker"));
set_perm(0, 0, 0700, "/tmp/sony_version_checker");
assert(package_extract_file("system/build.prop", "/tmp/build.prop"));
if (getprop("ro.build.type") == "user") then (
  if (run_program("/tmp/sony_version_checker", "/tmp/build.prop") != 0) then (
    abort("package is too old.\n");
  ) endif;
) endif;
So, it will check the device first, then extract and run sony_version_checker. If it errors out for any reason, it throws the "package is too old" error. Now, this reason is probably the fact that the package is mismatched (EU != US).
DOMin8or
Android 1.0
Posts: 8
Joined: Mon Oct 01, 2012 6:29 am
GTV Device Owned: Sony NSZ-GS7 (v2 streamer)
Location: Cologne/Germany

Re: OTA Update.zip for NSZ-GS7

Post by DOMin8or »

and removing of

if (getprop("ro.build.type") == "user") then (
if (run_program("/tmp/sony_version_checker", "/tmp/build.prop") != 0) then (
abort("package is too old.\n");
) endif;

isn`t it an option? so the abort() function cant be called...
or inject the last line in the checker run_program() function with static output variables...
so the function will give all times green light.

or will this end in an md5 collision?
cj_000
1.6 Donut
Posts: 121
Joined: Fri Jul 29, 2011 2:13 pm

Re: OTA Update.zip for NSZ-GS7

Post by cj_000 »

Yep, it's not possible - issue is that script is stored inside of the update, that is RSA verified (like, just about every android update) now, so we can't modify it at all.
nighthawknoir

Re: OTA Update.zip for NSZ-GS7

Post by nighthawknoir »

I can now confirm that it's only checking the version number and not the region after buying a fresh unit and trying again.

For everyone wanting to flash the US firmware on a non-US device in order to have Netflix (which is integrated in the system and not an ordinary app):
- Do NOT apply the OTA update when asked (until a link to a US version greater or equal to your current version is available)
- Flash the latest US firmware (which should meet the requirements) as described here: http://gtvhacker.com/index.php/Sony_NSZ ... te_History
- Note: The connect button can be found at the bottom of the device

Bonus:
- Configure your router running DD-WRT for selective VPN routing: http://www.dd-wrt.com/phpBB2/viewtopic.php?p=710955

EDIT: You can now also switch from the latest OTA update to the US version because the link is now available: http://forum.gtvhacker.com/nsz-gs7-stre ... c1084.html
Post Reply
 

 

cron