New Revue User

Got something to discuss and it doesnt fit in the other catergories, place it here.

Moderator: Revue Mod

Post Reply
Android 1.0
Posts: 1
Joined: Wed Sep 18, 2013 7:53 am
GTV Device Owned: Logitech Revue

New Revue User

Post by MTXRooster »

Hey all.. Picked up one of these units at a thrift sale.. I know their End-of-Lifed, but.. Well, I'm no stranger to modding hardware and whatnot, so I figured with all the info around on these, I'd give it a shot.

So... I hit my first obstacle, and now I'm stumped, lol :( My unit had 2.1_update1 on it. It doesn't have the keyboard, but I've been using a usb keyboard and thought I'd try to use the android app on my phone. USB keyboard works fine - But paring the phone after entering the code kept giving me com logitech.harmony crashes, non-stop. Since the unit wasn't "factory new" (meaning the previous user left it as is when they ditched it), I went to the settings area and tried an update and was told what I had was current. I then did the factory reset on it. When it rebooted, it ran me through the initial setup, which eventually on the last step 9/9, crashes while it's "downloading something" (doesn't say what, just shows the whirling busy animated icon). Went searching the net, discovered 3.1 and/or 3.2 are available, read many guides, many which seem to be reposts and every guide insists I MUST update to 55579 before installing 'the latest and greatest' version. Problem is, NO ONE has this mythical version. Every link is dead. Every file name search turns up either 404's or file not found.


I'm at v2.1_update1... Could someone please point me to some form of upgrade file that will work?
For reference:
(the guide from here that I tried to follow.. Went ahead and tried it anyway, since seemingly no one on the internet HAS that 55579 version, and it fails the has/checksum, assuming that is part of the issue of trying to update from 55579...?

Also wondering.. Did these units have a 'standard' product ID sticker or anything? On the bottom there's a decent sized indent, but there are only two stickers there, a MAC and a serial number.. No logitech sticker with a formal model number or anything.. I ask because on the front of the unit, there is a while label maker printed label which reads "developer edition". Sticker totally looks like from one of those Brother P-Touch type, so I'm 99% sure it was done by the previous owner, and not something unique and special from Logitech, but still.. The lack of a formal part number/model number on the bottom makes me curious..

Will continue searching the forums here, but would really appreciate some help on this in the form of working file locations or any other input. Read there was a gtv group working on modded firmware - Maybe that would be an option? Only the wiki claimed it to be more of a proof of concept and not necessarily functional..? Willing to try anything :) Thanks in advance!

EDIT: Still haven't found any files.. Tried usb flashing/recovery mode using B51795 as well as B54202, both located from a wiki, one claims bad signature, the other claims the is not a supported file (paraphrasing).. Neither build are the minimum stated to be needed however..

I did manage to get it to get past all the com logitech.harmony errors during setup.. After it verified a network connection (which you can't skip) and verified the "latest version" (again, I'm only running 2.1_update1, says that's the latest) I unplugged the network. It whirred a bit, think it spit an error, but then finally said congratulations it was going to reboot and save the configuration.. Got the gui now, but still spitting errors at me from logitech like listed above. Wondering if the 3.1/3.2 update will resolve that?

My build number (is not listed in any wiki/database??) is: ka2x-20101123.200533.user-b41819. Not sure why there's no listing of it? :(

As an aside - For those who still have this unit - What are you doing with it these days?
Android 1.0
Posts: 1
Joined: Fri Sep 27, 2013 5:54 am
GTV Device Owned: Logitech Revue

Re: New Revue User

Post by mattkelly »

Good luck with your errors! I wish I knew enough to be able to help. :geek:

I am a new Revue user as well. Got it from a friend as a sort of "hand me down". I was hoping to be able to run RetroArch, XBMC, etc.

Nothing as worked yet, but I'll be sure to report back here once I get something up and running.
Android 1.0
Posts: 3
Joined: Wed Nov 21, 2012 7:09 am
GTV Device Owned: NSZ-GT1 (Bluray Player)

Re: New Revue User

Post by ChrisG8 »

I used a Revue almost daily for over 2 years but I can't help with those errors. I retired it a few months ago but it served me well. As far as any useful hacks, I am not aware of anything for the things I want from Google TV. I have switched to two Sony models, the NSZ-GT1 and NSZ-GS7. For what I want from Google TV, both are an upgrade but I use the Logitech Revue K700 keyboard to operate both Sony models since I prefer it to those little qwerty keypad controllers.

If some kind of useful hack for the Revue is developed, I am certainly open to placing it back in service.
Post Reply